When syncronization the AD thumbnailPhoto into SharePoint UserProfile Service is not working

1. incremental import

2. check Sync DB

Select sAMAccountName,SPS_MV_OctetString_PictureURL from MMS_Metaverse with(nolock) Where SAMAccountName like ‘%UserName%’

3. Check Profile DB

Select NTname,PictureURL from UserProfile_full with(nolock) where NTName like ‘%harmeet%’

if nothing there… run below script

4. powershell script

Update-SPProfilePhotoStore -CreateThumbnailsForImportedPhotos 1 -MySiteHostLocation http://mysite

 

reference from :

http://blogs.technet.com/b/harmeetw/archive/2011/09/10/importing-thumbnail-photos-from-ad-active-directory-into-sharepoint-2010.aspx

http://blogs.technet.com/b/steve_chen/archive/2010/09/20/user-profile-sync-sharepoint-2010.aspx

 

 

if someone delete the ‘Users Phots’ Picture library below message can be shown.

Your personal site does not contain a picture library named ‘Pictures

 

reference from : (Ryan’s answer)

http://sharepoint.stackexchange.com/questions/23419/how-do-i-fix-the-error-your-personal-site-does-not-contain-a-picture-library-na

 

 

 

 

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: